Creating Word Clouds

To create a word cloud for documents or codes or quotations select one or more items e.g. in the Project Explorer or in the respective manager.

You can always add or remove more items of the same entity type to the cloud or list, once the word cloud has been created.

In the Project Explorer, right-click and select the option Word Cloud. In a manager, select the Word Cloud option from the ribbon.

Creating a word cloud for selected documents

Other options are:

  • to load a document first and select the Word Cloud button in the ribbon.
  • to open a manager and select the Word Cloud button in the ribbon.

When you select to create a word cloud from codes, the word cloud shows the words of the quotations coded with the selected code(s).

Word Cloud showing frequency for a word

When you hoover over a word, its frequency is shown (= token / number of occurrences of a unique word).

Setting the Scope

Once you created a word cloud, you see a side panel on the left. The check-boxes of the currently active entities are checked. You can check further entities or uncheck already activated entities.

Setting the scope for a word cloud

You can also change the entity type. Options are to change between:

  • documents
  • document groups
  • codes
  • code groups
  • quotations

Change entity type

Another scope option is to enter a search term into the search field to look for a specific document, code, or quotations that only contain specific words.

World Cloud Ribbon

The Word Cloud ribbon provides several options:

Word Cloud ribbon

Show Scope: You can activate or deactivate the side panel that allows you to select the scope.

Spiral: Display of the words in a spiral (default).

Typewriter: Display of words from left to right. You can select whether to list the words in alphabetic order, by frequency of occurrence of by word length in either ascending or descending order.

Sorting: The word cloud can be sorted in alphabetical order, by frequency or word length.

Threshold: My moving the slider from left to right, you can determine that only words with a certain frequency are displayed. The number of the left-hand side shows the lowest, the number on the right-hand side the highest occurring frequency.

Exclude: You can exclude single character words, numbers, hyphens and underscores.

Stop / Go Lists: To exclude particular words, you can select stop lists. If only certain words should be displayed, you can create a Go List. See the section on "Stop and Go Lists" below.

Filter

  • Ignore Case: Select this option, if you do not want to count words separately depending on whether they contain upper or lower case letters.

  • Show Inflected Forms: The plural forms of nouns, the past tense, past participle, and present participle forms of verbs, and the comparative and superlative forms of adjectives and adverbs are known as inflected forms. If you activate this options, the word cloud only shows the basic form of the word, e.g. building but not buildings.

Export: You can save a word cloud as graphic file (.jpg).

Filter Tab

Word Cloud Filter tab

Character Filter: In this section you can enter special characters that you do not want to be counted and displayed in the word cloud. By default, the following characters are excluded:

|"(){}[]<>/#+-_%$&“”´`@^‘„

You can select whether these characters should generally be removed or only at word ends.

If you add or remove characters, or deactivate the restriction to word ends, you can click on the Reload button. This updates the word cloud.

Context Menu Options

When you right-click on a word, you have the following options:

  • Remove from Word Cloud
  • Add to Stop List
  • Copy to Clipboard
  • Search in Context

Word Cloud context menu options

The option Remove from Word Cloud temporarily removes the word from the cloud.

If you have selected a stop list (see below), you can add more words to it. The option will be grayed out as shown in the image above, if no stop list has been selected yet.

The Copy to Clipboard option is useful, if you want to run the auto coding tool based on some words in the word cloud. See Text Search.

The Search in Context option opens the Project Search and shows the selected word in its context.

Showing a word in context

Stop and Go Lists

Words in stop lists are words which are filtered out when processing text. Stop words are short function words that occur very often and which do not convey any particular meaning. Examples are 'the', 'a', 'you', 'is', 'at', 'on' and 'which'. ATLAS.ti offers predefined stop lists in 35 languages. These stop lists are based on the information provided by Ranks NL.

In contrast, if you set a word list as Go List, then only the words that are in the list are counted.

Selecting a Stop List

To select a stop list, click on the drop-down button for Exclude

Selecting a stop list

Importing a Stop List

If you have been importing an older version 8 project, the selection list might be empty:

Empty selection list

All available stop lists are however already on your computer. They were copied during the installation on ATLAS.ti. To retrieve them:

Click on the Edit button and select Import Lists.

Import existing stop or go lists

This brings you do the directory where all stop lists that come with ATLAS.ti are stored:

C:\Users...\Documents\Scientific Software\ATLASti.9\Stopwords

Stop Lists that are delivered with ATLAS.ti

Select all lists that you want to use and click Open.

Close the window, return to the word cloud and select a stop list.

Below you see an example for a word cloud where a stop list was applied:

Word Cloud with applied stop list

Cleaning up a Word Cloud

In the word cloud above, there are still a lot of words that distract from the content of the interviews like all speaker IDs: INT, SHAZ, DEB, AL, STU.

You can either remove the words from the current cloud, or add the words the stop list. Then they are also not counted in other word clouds that you create later.

To remove a word from a word cloud temporarily, select the word, right-click and select "Rmove"

If you want to remove it from all word clouds permanently:

Right-click on a word and select Add to stop list.

Remove a word from a word cloud

The cleaned up word cloud might look as follows:

Cleaned up Word Cloud

Creating a New Stop or Go Lists

In the ribbon in the section Stop/Go Lists, click on the Edit button.

Edit stop or go list

In the next window, select New List from the ribbon.

Create new stop or go list

Enter a name for the list and select as list type: Stop List or Go List. Enter an optional comment to describe the purpose of the list.

Click Create.

Enter a name for the new stop or go list

To add words to the newly created list, click on th New Word button a few times. Every time you click, a new field is added where you can enter a word.

RegEx: You can enter regular expressions, if you want to enter specific terms to the list. If so, you need to tick the Regex box. Optionally you can write a comment that explains the regular expression.

Add words to a stop or go list

You can turn a stop list into a go list (or vice versa) by changing the List Type. Other options in the ribbon are to duplicate and to delete word lists.

Change list type

Exporting a Stop or Go List

Exporting a stop or go list allows you to:

  • share it with other users
  • use it in another project

In the ribbon, click on Export List. A file manager opens. Select a location and enter a name and click on Save.

The list is saved as Excel file.

Creating a User-Defined Stop or Go List in Excel

Importing a user defined list works as follows:

Export an existing list and open it in Excel. It serves as a template.

In Excel, change the name of the list, but leave all the header information as is. If you want to prepare a go list, enter 'no' in the second column/second row under Stop List.

Now delete all words and replace them with new words, one word per row.

Prepare a list in Excel

Save the list under a new name and import it.